AVR1900: Getting started with ATxmegal28A1l
on STK600

1 Introduction

This document contains information about how to get started with the
ATxmegal28Al on STK®600.

The first three sections contain information about the software (AVR Studio®,
WIinAVR and IAR Embedded Workbench® for AVR®) needed to compile and debug
code for ATxmegal28Al. The next section contains a brief overview on how to set
up the STK600 for ATxmegal28Al. The final section shows how to create a
project and compile code for ATxmegal28A1 using IAR Embedded Workbench or
WIinAVR, and how to start debugging the code on the STK600 using AVR Studio
and JTAGICEmKII.

More Information about where to find the software tools can be found in chapter 7.
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2 AVR Studio that supports ATxmegal28Al

AVR Studio is used to debug code. It contains a simulator and a frontend for the
JTAGICE mKIl for doing on chip debugging on AVR XMEGA. To have support for
STK600 and ATxmegal28A1, AVR Studio version 4.14 or later must be installed.

Note: During installation of AVR Studio remember to install the USB driver.

3 Installing IAR Embedded Workbench 5

4 Installing WinAVR

2 AVR1900

IAR Embedded Workbench 5.10 (or later) for AVR (IAR EW Evaluation and Full
version) has compiler support for ATxmegal28A1.

To start the installation use the autorun application, then select “Install IAR
Embedded workbench”.

Figure 3-1: Installing IAR EW for AVR.

Welcome to IAR Systems
IAR. Embedded Workbench®

w7 Install Install IAR Embedded Workbench®
¢ IAR. Embredded Workbench® on your computer. This includes
project handler, editor, compiler,

b, B assembler, linker and debugger
mi

OB Y Y

©IAR

www.iar.com SYSTEMS

During installation it is possible to use the same License number and License key as
for previous versions of IAR Embedded Workbench.

It's recommended to use the default settings during the installation of IAR. How to
start a project in IAR EW is presented in chapter 6.1.

Download WInAVR release 20080411 (or later) from Sourceforge. Run the installer
and follow the instructions. The avr-gcc toolchain will integrate with AVR Studio
automatically. How to start a project in WinAVR is presented in chapter 6.2.
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5 Setting up STK600 for ATxmegal28A1l

STK600 is designed to support all 8-bit AVR devices and AVR32 devices with flash. A
system based on socket and routing cards is used to support different package types
and pinouts on the STK600 board.

Figure 5-1: STK600 socket and routing system

Socket board

Routing card

STK600

Before using the STK600 and before mounting any socket and routing card it is
recommended to check that STK600 contains the newest firmware and that it has the
right VTarget voltage. This can be done as described below.

Note: AVR Studio should be installed before connecting to the STK600 to ensure that
the drivers are installed.

Connect a USB cable to the STK600 and turn it on.
windows® will tell you that new hardware is found. Install the driver for STK600.
Open AVR Studio and cancel the startup dialog.

Start a connection with STK600 by selecting “Tools -> Program AVR ->
Connect...” from the menu and select the STK600 and USB as illustrated in Figure
5-2.

A ownbdpR

Figure 5-2: Connect to the STK600.

Select AVR Programmer

Platform: Fart:

STKS00 or SYRISP | comnect.. |
JTAG ICE
JTAGICE mkll

Cancel

AVRISE mkll |
AW Dragon

Baud rate:

[~

B aud rate changes are

. . ) active immediately.
Mate that a tool cannot be uzed for programming as long az it i connected in

a debugaing sezsion. |n that caze, select 'Stop Debugging' first.

Tip: To auto-connect to the programmer uged lazst ime, press the 'Programmer’
button on the toolbar.

Dizconnected Mode. . |

AIMEL 3

I (5

8107A-AVR-04/08



ATMEL

1. If a newer firmware version for the STK600 is available AVR Studio will ask if you
what to do an upgrade. Follow the instructions given by AVR Studio to do the
firmware upgrade.

2. After the upgrade connect to the STK600 again (in the same way as 4.) and open the
HW Setting page. Set VTarget voltage between 1.8 V and 3.6 V and write the value to
STK600. A read back to verify that the right value was written is recommended.

Figure 5-3: Set the VTarget voltage

STK600 in PDI mode with ATxmega128A1

Main ] Proglam] Fuses ] LockBits ] Advanced HW Settings IHW Info] Auto ]

Yoltages
WTarget: _I 33 v
AREF (: _} 330 y
AREF 1: _} 330 v
Fead Write
Clock Generator
2003 MHz
: | [B003456
. | . 2003456
Fead | Write

Firmware Upgrade

e

Getting VTARGET.. 3.3V . OK
Getting AREFD.. 3.30 V.. OK
Getting AREF1.. 3.30 V.. OK
Getting oscillator parameters.. OK

When the newest firmware and the right target voltage is set, turn off the STK600
before mounting the routing card and socket card.

The routing card used for ATxmegal28Al is “STK600 — RC100X- 13" and the socket
card used for 100 pin devices is “STK600 — TQFP100”

How to mount the routing card and socket card to the STK600 is shown in Figure 5-4.
It is not possible to mount the routing and socket card in a wrong orientation.
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Figure 5-4: How to mount the routing and socket card to the STK600
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When mounting the device in the ZIF socket ensure it is mounted in the correct
orientation. Pin one on the device is marked with a dot. As seen on Figure 5-5 this
corner must be orientated in the same direction as the cut corner on the socket.

Figure 5-5: Mounted device in ZIF socket

The STK600 can source power trough the USB cable. Remember that the power
available trough the USB cable is limited. If the STK600 is connected to external
hardware that consumes more than 300mA, you should use an external power source
connected to the DC input socket on STK600. The external power supply should be
10-15V DC with positive center connector.

Debugging of the code is done with AVR Studio and JTAGICEmkII. How to do On-
Chip Debugging using the JTAGICE mkll to STK600 is described below:

1. Connect the JTAGICE mkll to the STK600 as show below:
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Figure 5-6: Connecting JTAGICE mkll to STK600.

2. Turn on power on STK600 and JTAGICE mkill. (If it is the first time JTAGICE mkKill
is used, Windows will ask you to install the driver.)

More information about STK600 and JTAGICE mKll is available in AVR Studio. (Help
-> AVR Tools User Guide).

6 Compiling code and debugging code on chip

This section describes how to make a project, compile and debug on-chip with both
IAR EW and WIinAVR. For development with IAR EW read chapter 6.1. For
development using WinAVR read chapter 6.2.

6.1 Compiling and debugging with IAR and AVR Studio

To start a project for the ATxmegal28A1 device in IAR EW AVR do as described
below:

e Open IAR Embedded Workbench
e Select “Project -> Create New Project..” in the menu
e Select the desired coding language with AVR Studio 4 compatible output.
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Figure 6-1: Create new project in IAR EW for AVR
Create New Project g|

Tool chair: &R |

Project templates:

Ermpty project S
+- azm
+|- C4++

® Studio 4 compatible output

mair
L
N

Dezcription:

C project uzing default tool settings including an empty main.c file,
The output iz compatible with 2WFE Studio 4.

| ] | Cancel |

e Save the project in the desired location <project location>.
e Open project options (Project -> Options or ALT+F7)

e In the General Option Category, select the Target tab and set the Processor
configuration to ATxmegal28A1 as shown in the figure on the next page.

Figure 6-2: Processor configuration.

Categony:
zeneral Options
C/C++ Compiler Target l Dutput] Library Configuration | Library Elpticunxl Heap Configu 4 | *
Aszembler . .
) Processzor configuration
Zustom Build
Build Actions |--u:|:uu=:<m'| 2851, ATxmegal 2841 ﬂ
Linker —~cpu=ting3E1, ATtinpSE1 A
—cpu=uszbl286, ATI0USE1286
Debugger ~cpu=ush1 287, ATI0USE1287
CCR ~cpu=ush162, ATA0USETEZ
ICEZa0 ~opu=usbB4E, ATS0USER4E
ITAGICE —cpu=uzbBds, ATI0USEE4Y
ITAGICE I'ﬂkII --u:u=us|:|, AEIDLISEBE
Simulaker | [ B o ] RITEC
Third-Party Driver | Small

Syztem configuration
[v Configure spstem using dialogs [nat in <CL file]

[/

QK ‘ Cancel
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e To enable bit definitions in 1/O space, open the system tab and check out the
“Enable bit definitions in 1/0O- Include files” box.

Figure 6-3: Enable I/O bit definitions from include files.

Category:
General Cptions
CJC++ Compiler Library Options ] Heap Configuration  System l MISRA E] 1]k
Eif;“r:'g;l ; Data stack [CSTACK) Bieturn address stack [RGTACK)
Build Actions Size [bytes] U200 size [levels]: |18
Linker I -
Debugger
R
ICE200 [ Enable external memory bus
ITAGICE B
ITAGLCE mkII
Simulakor | | |
Third-Party Driver

[v Initialize unused intemupt vectars with BET instructions
[v Enable bit definitions in |/0-nclude files

]4 | Cancel

e Include ioavr.h in your files that shall use 1/O bit declarations.

e Compile your code pushing the “Compile” button or selecting compile from the
Project menu, or simply press “Ctrl+F7”

e Make an output file for AVR Studio by pushing “Make” button or selecting make
from the Project menu, or simply press “F7”

e For debugging the program make the connections as described in chapter 5.
Open AVR Studio and click on the “Open” button in the startup dialog. Go to the
location where you saved your project in IAR. In the project directory, locate the
Debug folder, and the “Exe” inside. The “Exe” folder contains the d90 file, which is
IAR’s debug output file for AVR Studio. Open this d90 file in AVR Studio.
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Figure 6-4: Open IAR debug output file in AVR Studio
Open Project File or Object File

Loak in: |L'f) Exe j

\2-.. || 4ES_example.dso

ky Recent
Documents

—

Deskiop

i,

My Documents
rdy Computer

ky Hetwark, Fil= name:

|.&ES_E:<am|:nIe j Open |
Flaces
Files of type: |F'n:-iect Files, Object Files [“.aps,“.hex;“.dﬁﬂ;".afﬂ Cancel

g

Studio will then generate an AVR Studio Project File that needs to be named and
saved.

Select JTAGICE mkll as debug platform and ATxmegal28A1l as device as shown
on the next page.

Figure 6-5: Select debug platform.

Select device and debug platform

Select debug platform and device
Debug platiorm:

Device:

AR Dragon AThingdB1 -
AWF Simulator ATtinp48 ]
AVE Simulator 2 AThirgSd

ICE200 ATtingE5

ICE4N ATtingE1

ICERD ATtingEa

JTAG ICE 288

JTAGICE mikll ATumegabdal =

Part: |Auta »| [ Open platform options

Yer 4.14.585

Firnzh Cancel Help
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When this is done the debug session is started. More information about AVR Studio
and debugging in AVR Studio are found in “AVR Studio User Guide” (Help-> AVR
Studio User Guide)

6.2 Compiling and debugging with WinAVR and AVR Studio

To start a project for the ATxmegal28A1 device in WinAVR and AVR Studio do as
described below:

e Open AVR Studio
e Select “Project -> New Project” from the menu

e Select AVR GCC in the pop-up window and type in the project name and file as
shown below:

Figure 6-6. Create new AVR GCC project

Create new project

Project type: Froject name:

& Atmel 4R Assembler Im_l,lpn:-iect

3 AR GLC
I Create initial file [+ Create folder
Iitial file:
|m_l,lpru:|iec:t .

Location:

[558 J

ver 414579 | Show dialog at startup

I MHemt > | Firish J Cancel I Help J

e Press “Next>>" and select “JTAGICE mkll” in the Debug platform, and
“ATxmegal28A1l1” as Device:
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Figure 6-7. Debug platform and device

Select device and debug platform

Yer 4.14.585

Select debug platform and device

Debug platiorm: Device:

AR Dragon AThingdB1 ”
AVE Simulator AThirpdd

AVE Simulator 2 AThirgSd

ICE200 ATtingE5

ICE4N ATtingE1

ICERD ATtingEa

JTAG ICE ATxmegal 284

JTAGICE mikll ATumegabdal =

i
Part: |Auta »| [ Open platform options
Firnzh Cancel Help

e Press “Finish” and the project will be created
e Select “Project -> Configuration Options” from the menu

e In the configuration window, select “atxkmegal28Al” in the device option and

select the wanted optimization level and press the OK button.

Figure 6-8. WinAVR Project options

myproject Project Options

§5
Sk
Ll'\.\r"'

General

Include
Directories

&

Libraries

"
|
Memory Settings
o

=
E=

Custom Optior X

Active Corfiguration |defaurt

j Edit Configurations

[~ Use Exdemal Makefile |

|

Output File Name: |rrr:,'pr0ject.elf

Output File Dirsctory: |default’

Device: 7
Frequency: hz
Optimization: | s -

v Create Hex File

¥ Generate Map File

Iv Unsigned Chars (funsigned-char)

Iv Unsigned Bitfields (funsigned-bitfields)
[v Pack Structurs Members (fpack-struct)
[v Short Enums (fshort-enums)

v Generate List File

QK | Cancel Help
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The project is now set up, and you can write your program in the C file. To compile
the program and debug it on the device, make the same connections as described in
chapter 5. Compiling your program can be done as follows:

e To compile only the active file, select “Build -> Compile” from the menu or pushing
the “Compile” button, or by simply pressing “Alt+F7”.

e To make the whole project, select “Build -> Build” from the menu or by pushing the
“Build” button, or by simply pressing “F7”

e The project is now build and you can debug the code on-chip by selecting “Debug
-> Run” from the menu or by pushing the “Run” button, or by simply pressing “F5”.

e The two previous steps can be done simultaneously by selecting the “Build ->
Build and Run” form the menu or by pushing the “Build and Run” button, or simply
by pressing “Ctrl+F7".

Your debugging session has now started and you can debug the program on-chip.
For more information about debugging, read the “Help -> AVR Tools User Guide” in
AVR Studio.
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For more detailed information about the ATxegal28A1l device, read the datasheet
and the XMEGA A Manual available at the Atmel® web pages:
e ATxmegal28Al datasheet:

0 http://www.atmel.com/dyn/resources/prod_documents/doc8067.pdf
e ATxmega A Manual:

0 http://www.atmel.com/dyn/resources/prod_documents/doc8077.pdf
o XMEGA Application Notes:

o http://www.atmel.com/dyn/products/app notes.asp?family id=607#X
MEGA%20Microcontrollers

Tools needed for development can be found here:
e AVR Studio
0 http://www.atmel.com/dyn/products/tools card.asp?tool_id=2725
¢ |AR Embedded Workbench (Evaluation or Full version)
0 http://lwww.iar.se/
0 http://supp.iar.com/Download/SW/?item=EWAVR-EVAL
¢ WInAVR
0 http://winavr.sourceforge.net/
0 http://sourceforge.net/project/showfiles.php?group id=68108
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